Trabalhando no Sherpa Designer#

A interface do usuário do Sherpa Designer, que é aberta por padrão, consiste nas seguintes áreas principais:

  1. Menu principal (painel superior).
  2. Painel principal (painel esquerdo).
  3. Área de trabalho central.
  4. Painel de propriedades (painel superior direito).
  5. Painel "Variáveis" (painel inferior direito).
  6. Painel central inferior.
№ p/pElemento da interfaceDescrição
1."Menu principal"

Contém as principais ações para configuração e gerenciamento de projetos e diagramas de robôs. O menu principal inclui:

  • Menu "Arquivo";
  • Menu "Navegação";
  • Menu "Gravação";
  • Menu "Depuração";
  • Menu "Avançado";
  • Menu "Ajuda".
1.1.menu "Arquivo"

Contém ações necessárias para trabalhar com projetos:

  • Criar;
  • Abrir;
  • Salvar;
  • Propriedades do projeto;
  • Migrar;
  • Git commit;
  • Publicar.
1.2.menu "Navegação"Permite navegar entre os diagramas de robôs.
1.3.menu "Gravação"

Contém ações necessárias ao trabalhar com a gravação de ações do usuário em aplicativos e em recursos da web, bem como com a extração de dados pelo gerador de modelos:

  • Gravar;
  • Computer Vision;
  • Extrair dados;
  • Extrair por modelo;
  • Reconhecer.
1.4.menu "Depuração"Contém ações necessárias para iniciar a depuração do robô, bem como a depuração remota do robô.
1.5.menu "Avançado"

Contém ações adicionais para trabalhar com diagramas de robôs:

  • Sherpa Explorer;
  • Sherpa Regex;
  • Editor de janelas;
  • Construtor de consultas.
1.6.menu "Ajuda"Permite acessar materiais de treinamento: vídeos de treinamento, exemplos de uso do programa, projetos de demonstração.
2.Painel principal

O painel principal inclui as seguintes abas:

  • Blocos;
  • Solução;
  • Biblioteca;
  • Autodesigner.
2.1.Aba "Blocos"Permite abrir a paleta de blocos funcionais para a criação de projetos.
2.2.aba "Solução"Permite armazenar e combinar vários projetos independentes em uma única solução, para gerenciá-los centralmente.
2.3.aba "Biblioteca"Permite abrir a biblioteca de processos prontos.
2.4.aba "Autodesigner"Abre a ferramenta de IA do Sherpa Designer: por meio de um chat de texto, é possível criar e depurar robôs do zero, corrigir e ampliar projetos existentes, verificar e ajustar seletores, fazer perguntas sobre o projeto, realizar auditorias e preparar trechos de documentação.
3.Área de trabalho central

A área é destinada ao trabalho com os blocos do diagrama do processo atual.


4.Painel de propriedadesO painel é destinado ao gerenciamento das propriedades do bloco selecionado no diagrama.
5.painel "Variáveis"O painel é destinado à exibição das variáveis do diagrama do processo atual.
6.Painel central inferiorO painel é destinado à exibição dos logs de todas as ações do robô de software.
6.1.aba "Log"Permite visualizar os logs de todas as ações do robô de software.
6.2.aba "Variáveis"Permite visualizar todas as variáveis existentes do processo atual.
6.3.aba "Console"Permite trabalhar com o console do robô.

Além disso, a interface do usuário do Sherpa Designer possui um painel de ferramentas adicional que se abre ao clicar na aba "Ferramentas" na parte superior da interface.

№ p/pElemento da interfaceDescrição

menu "Edição"

Contém ações necessárias ao trabalhar com os blocos do diagrama do robô:

  • Inserir;
  • Cortar;
  • Copiar;
  • Excluir;
  • Localizar;
  • Localizar próximo;
  • Substituir.

menu "Diagrama"

Contém ações necessárias para construir o diagrama do robô:

  • Alinhar;
  • Posição;
  • Verificação completa dos blocos;
  • Remover variáveis não utilizadas;
  • Compilar blocos de chamada de código.

menu "Projeto"

Contém ações necessárias para a manutenção e verificação do projeto no Sherpa Designer:

  • Documentar...;
  • Comparar versões;
  • Verificação completa dos blocos;
  • Remover variáveis não utilizadas;
  • Compilar blocos de chamada de código.

menu "Parâmetros"

Contém ações necessárias ao trabalhar com os parâmetros do programa:

  • Gerenciador de pacotes;
  • Parâmetros do programa.

menu "Ferramentas"

Contém ações necessárias para uma configuração conveniente da interface:

  • Russo (Rússia) - idioma;
  • Tema;
  • Atualizar diagrama.

Na barra superior do Sherpa Designer há botões para desfazer e refazer a última ação: os botões e , respectivamente. Além disso, algumas ações do menu principal do Sherpa Designer também são duplicadas pelos botões.