Working in Sherpa Designer#

The default user interface of Sherpa Designer consists of the following main areas:

  1. Main menu (top panel).
  2. Main panel (left panel).
  3. Central workspace.
  4. Properties panel (upper right panel).
  5. Variables panel (lower right panel).
  6. Lower central panel.
No.Interface ElementDescription
1."Main Menu"

Contains the main actions for configuring and managing projects and robot diagrams. The main menu includes:

  • File menu;
  • Navigation menu;
  • Record menu;
  • Debug menu;
  • Advanced menu;
  • Help menu.
1.1.File menu

Contains actions necessary for working with projects:

  • Create;
  • Open;
  • Save;
  • Project properties;
  • Migrate;
  • Git commit;
  • Publish.
1.2.Navigation menuAllows navigation between robot diagrams.
1.3.Record menu

Contains actions necessary when working with recording user actions in applications and on web resources, as well as with data extraction by the templater:

  • Record;
  • Computer Vision;
  • Extract data;
  • Extract by template;
  • Recognize.
1.4.Debug menuContains actions necessary for starting robot debugging, as well as remote debugging of the robot.
1.5.Advanced menu

Contains additional actions for working with robot diagrams:

  • Sherpa Explorer;
  • Sherpa Regex;
  • Window editor;
  • Query builder.
1.6.Help menuAllows access to training materials: training videos, examples of working with the program, demonstration projects.
2.Main Panel

The main panel includes the following tabs:

  • Blocks;
  • Solution;
  • Library;
  • Autodesigner.
2.1.Blocks tabAllows opening the palette of functional blocks for creating projects.
2.2.Solution tabAllows storing and combining multiple separate projects into one solution so they can be managed centrally.
2.3.Library tabAllows opening the library of ready-made processes.
2.4.Autodesigner tabOpens the Sherpa Designer AI tool: through a text chat you can create and debug robots from scratch, fix and extend existing projects, check and adjust selectors, ask questions about the project, perform audits, and prepare documentation snippets.
3.Central Workspace

This area is intended for working with the blocks of the current process diagram.


4.Properties PanelThe panel is intended for managing the properties of the selected block in the diagram.
5.Variables PanelThe panel is intended for displaying the variables of the current process diagram.
6.Lower Central PanelThe panel is intended for displaying logs of all actions of the software robot.
6.1.Log tabAllows viewing the logs of all actions of the software robot.
6.2.Variables tabAllows viewing all existing variables of the current process.
6.3.Console tabAllows working with the robot's console.

Additionally, the Sherpa Designer user interface has an additional toolbar that opens when you click the "Tools" tab at the top of the interface.

No.Interface ElementDescription

Edit menu

Contains actions necessary for working with the blocks of the robot diagram:

  • Insert;
  • Cut;
  • Copy;
  • Delete;
  • Find;
  • Find next;
  • Replace.

Diagram menu

Contains actions necessary for building the robot diagram:

  • Align;
  • Position;
  • Full block check;
  • Remove unused variables;
  • Compile code call blocks.

Project menu

Contains actions necessary for maintaining and checking the project in Sherpa Designer:

  • Document...;
  • Compare versions;
  • Full block check;
  • Remove unused variables;
  • Compile code call blocks.

Parameters menu

Contains actions necessary for working with program parameters:

  • Package manager;
  • Program parameters.

Tools menu

Contains actions necessary for convenient interface configuration:

  • Russian (Russia) - language;
  • Theme;
  • Refresh diagram.

The top panel of Sherpa Designer includes buttons for undoing and redoing the last action: the and buttons, respectively. Also, some actions from the main menu of Sherpa Designer are duplicated by the buttons.