Trabajo en Sherpa Designer#

La interfaz de usuario predeterminada de Sherpa Designer consta de las siguientes áreas principales:

  1. Menú principal (panel superior).
  2. Panel principal (panel izquierdo).
  3. Área de trabajo central.
  4. Panel de propiedades (panel superior derecho).
  5. Panel "Variables" (panel inferior derecho).
  6. Panel central inferior.
N°Elemento de la interfazDescripción
1."Menú principal"

Contiene las acciones principales para configurar y gestionar proyectos y diagramas de robots. El menú principal incluye:

  • Menú "Archivo";
  • Menú "Navegación";
  • Menú "Grabación";
  • Menú "Depuración";
  • Menú "Avanzado";
  • Menú "Ayuda".
1.1.menú "Archivo"

Contiene las acciones necesarias para trabajar con proyectos:

  • Crear;
  • Abrir;
  • Guardar;
  • Propiedades del proyecto;
  • Migrar;
  • Git commit;
  • Publicar.
1.2.menú "Navegación"Permite navegar entre los diagramas de robots.
1.3.menú "Grabación"

Contiene las acciones necesarias al trabajar con la grabación de acciones del usuario en aplicaciones y en recursos web, así como con la extracción de datos por el generador de plantillas:

  • Grabar;
  • Computer Vision;
  • Extraer datos;
  • Extraer por plantilla;
  • Reconocer.
1.4.menú "Depuración"Contiene las acciones necesarias para iniciar la depuración del robot, así como la depuración remota del robot.
1.5.menú "Avanzado"

Contiene acciones adicionales para trabajar con diagramas de robots:

  • Sherpa Explorer;
  • Sherpa Regex;
  • Editor de ventanas;
  • Generador de consultas.
1.6.menú "Ayuda"Permite acceder a materiales de capacitación: videos de entrenamiento, ejemplos de uso del programa, proyectos de demostración.
2.Panel principal

El panel principal incluye las siguientes pestañas:

  • Bloques;
  • Solución;
  • Biblioteca;
  • Autodiseñador.
2.1.pestaña "Bloques"Permite abrir la paleta de bloques funcionales para crear proyectos.
2.2.pestaña "Solución"Permite almacenar y combinar varios proyectos independientes en una sola solución para administrarlos de forma centralizada.
2.3.pestaña "Biblioteca"Permite abrir la biblioteca de procesos listos.
2.4.pestaña "Autodiseñador"Abre la herramienta de IA de Sherpa Designer: mediante un chat de texto se pueden crear y depurar robots desde cero, corregir y ampliar proyectos existentes, comprobar y ajustar selectores, hacer preguntas sobre el proyecto, realizar auditorías y preparar fragmentos de documentación.
3.Área de trabajo central

El área está destinada a trabajar con los bloques del diagrama del proceso actual.


4.Panel de propiedadesEl panel está destinado a gestionar las propiedades del bloque seleccionado en el diagrama.
5.panel "Variables"El panel está destinado a mostrar las variables del diagrama del proceso actual.
6.Panel central inferiorEl panel está destinado a mostrar los registros de todas las acciones del robot de software.
6.1.pestaña "Registro"Permite ver los registros de todas las acciones del robot de software.
6.2.pestaña "Variables"Permite ver todas las variables existentes del proceso actual.
6.3.pestaña "Consola"Permite trabajar con la consola del robot.

Además, la interfaz de usuario de Sherpa Designer tiene un panel de herramientas adicional que se abre al hacer clic en la pestaña "Herramientas" en la parte superior de la interfaz.

N°Elemento de la interfazDescripción

menú "Edición"

Contiene las acciones necesarias al trabajar con los bloques del diagrama del robot:

  • Insertar;
  • Cortar;
  • Copiar;
  • Eliminar;
  • Buscar;
  • Buscar siguiente;
  • Reemplazar.

menú "Diagrama"

Contiene las acciones necesarias para construir el diagrama del robot:

  • Alinear;
  • Ubicación;
  • Verificación completa de bloques;
  • Eliminar variables no utilizadas;
  • Compilar bloques de llamada de código.

menú "Proyecto"

Contiene las acciones necesarias para el mantenimiento y la revisión del proyecto en Sherpa Designer:

  • Documentar...;
  • Comparar versiones;
  • Verificación completa de bloques;
  • Eliminar variables no utilizadas;
  • Compilar bloques de llamada de código.

menú "Parámetros"

Contiene las acciones necesarias al trabajar con los parámetros del programa:

  • Administrador de paquetes;
  • Parámetros del programa.

menú "Herramientas"

Contiene las acciones necesarias para una configuración conveniente de la interfaz:

  • Ruso (Rusia) - idioma;
  • Tema;
  • Actualizar diagrama.

En la barra superior de Sherpa Designer hay botones para deshacer y rehacer la última acción: los botones y , respectivamente. Además, algunas acciones del menú principal de Sherpa Designer también se duplican con los botones.