Skip to content
Sherpa
En
EnEsPtRu
  • Knowledge Base
  • Contents
  • Sherpa RPA
    • Key Concepts
    • Deployment Diagram of Sherpa RPA
    • Installing Sherpa RPA
    • Getting Started
    • Working with Citrix
    • Working with RDP
    • External Monitoring and Logging
    • Sherpa Robot and Sherpa Assistant
    • Sherpa IDP (Template Creator)
    • Sherpa Designer
      • Key Concepts
      • Installing Sherpa Designer
      • Working in Sherpa Designer
      • REST Client
      • How to Host a Project on GitHub Using Sherpa Designer
      • Smart Assistant
      • Block Reference
        • Main Blocks
        • Application Automation
        • Browser Automation
        • Computer Vision Automation
        • Invisible Browser
        • OCR Automation
        • Orchestrator
        • SAP
        • Dialog Windows
        • Word
        • Excel
        • Outlook
        • Exchange
        • Automation R7 Office
        • ODS/ODT Automation
          • Create Document
          • Open Document
          • Save Document
          • Close Document
          • Get Cell Value
          • Write Value to Cell
          • Upload Data Table
          • Save Data Table
          • Add Sheet
          • Delete Sheet
          • Rename Sheet
          • Switch to Sheet
          • Copy Cells
          • Get Data from Range
          • Write Data to Range
          • Clear Range
          • Insert Data into Range
          • Text Search
          • Number and Names of Sheets
          • Insert Row/Column/Cell
          • Delete Row/Column/Cell
          • Get the Number of Rows and Columns
          • Set Font Color/Style
          • Set Cell Borders
          • Set Cell Sizes
          • Get Cell Color
          • Create Document
          • Open Document
          • Save Document
          • Close Document
          • Get Text from Document
          • Write Text to Document
          • Add Paragraph
          • Replace Text (ODT)
          • Replace All Variables in Text (ODT)
          • Replace Text (Docx)
          • Replace All Variables in Text (Docx)
          • Read Tables
          • Write Tables
          • Read a Single Table
          • Write One Table
          • Insert Table
          • Insert Image into Cell
          • Insert Text into Cell
          • Set Font in Cell
          • Insert Row/Column in Table
          • Delete Row/Column in Table
        • File System
        • Clipboard
        • Lists and Dictionaries
        • Data Tables
        • Date and Time
        • Email
        • PDF
        • Text
        • FTP/SFTP
        • Processes/Services/Windows
        • Terminals
        • Registry
        • 1C
        • Databases
        • Google Sheets
        • Remote Desktop RDP/Citrix
        • Working with Archives
        • Business Functions
        • Images
        • Max
        • Telegram
        • Credentials and Security
        • Machine Learning
        • Text Analysis in NLP
        • S3 Storage
        • SSH
        • Sherpa AI Server. Folders and files
        • Sherpa AI Server. Model Requests
        • Sherpa AI Server. Agent Chats and Launches
      • URLs for Online Service Blocks
      • Robot Examples
      • Setting Up Robot Launch via Windows Task Scheduler
      • Migrating Robots from Windows to Linux
      • Operation of Attended Robots on Virtual Machines
      • Sherpa Designer: Frequently Asked Questions
    • Sherpa Orchestrator
  • Sherpa Process Discovery
  • Sherpa AI
  • Releases
  • Licenses
  • Security
  • Sherpa RPA Academy
  • Videos with Examples of Sherpa RPA Platform Work
  • Links to Distributions
  • Products in the Russian Software Registry
  • Contacts
Sherpa RPA/Sherpa Designer/Block Reference/ODS/ODT Automation

ODS/ODT Automation#

Here are the articles in this section:

Create DocumentOpen DocumentSave DocumentClose DocumentGet Cell ValueWrite Value to CellUpload Data TableSave Data TableAdd SheetDelete SheetRename SheetSwitch to SheetCopy CellsGet Data from RangeWrite Data to RangeClear RangeInsert Data into RangeText SearchNumber and Names of SheetsInsert Row/Column/CellDelete Row/Column/CellGet the Number of Rows and ColumnsSet Font Color/StyleSet Cell BordersSet Cell SizesGet Cell ColorCreate DocumentOpen DocumentSave DocumentClose DocumentGet Text from DocumentWrite Text to DocumentAdd ParagraphReplace Text (ODT)Replace All Variables in Text (ODT)Replace Text (Docx)Replace All Variables in Text (Docx)Read TablesWrite TablesRead a Single TableWrite One TableInsert TableInsert Image into CellInsert Text into CellSet Font in CellInsert Row/Column in TableDelete Row/Column in Table
← BackSet Cell SizesNext →Create Document
Last updated: 8 April 2026